您的位置:首页 > 其它

PAT甲级练习题A1025. PAT Ranking (25)

2016-08-17 21:09 399 查看

题目描述

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2

5

1234567890001 95

1234567890005 100

1234567890003 95

1234567890002 77

1234567890004 85

4

1234567890013 65

1234567890011 25

1234567890014 100

1234567890012 85

Sample Output:

9

1234567890005 1 1 1

1234567890014 1 2 1

1234567890001 3 1 2

1234567890003 3 1 2

1234567890004 5 1 4

1234567890012 5 2 2

1234567890002 7 1 5

1234567890013 8 2 3

1234567890011 9 2 4

题目解析

注意最后输出的顺序要求;

这里需要计算local_rank;

注意计算rank时,同分的同级,但是下一级相应要变大,1224而不是1223;

注意相同rank的按ID升序输出;

代码

#include<iostream>
#include<vector>
#include<algorithm>
#include<string>
using namespace std;

struct testee
{
string id;
int final_rank;
int local_rank;
int local_num;
int grade;
};

int main()
{
int N, K;
cin >> N;
vector<testee>all;
for (int i = 1; i <= N; ++i)
{
cin >> K;
vector<testee> local_group;
for (int j = 0; j < K; ++j)
{
testee te;
cin >> te.id >> te.grade;
local_group.push_back(te);
}
sort(local_group.begin(), local_group.end(), [](testee &a, testee &b) {return a.grade > b.grade; });
for (int j = 0, rank = 1; j < local_group.size(); ++j)
{
if (j != 0 && local_group[j].grade < local_group[j - 1].grade)
rank = j + 1;
local_group[j].local_rank = rank;
local_group[j].local_num = i;
all.push_back(local_group[j]);
}
}
sort(all.begin(), all.end(), [](testee &a, testee &b) {if (a.grade > b.grade) return true; else if (a.grade == b.grade&&a.id < b.id)return true; else return false; });
cout << all.size() << endl;
for (int i = 0,rank=1; i < all.size(); ++i)
{
if (i != 0 && all[i].grade < all[i - 1].grade)
rank = i + 1;
all[i].final_rank = rank;
cout << all[i].id << " " << all[i].final_rank << " " << all[i].local_num << " " << all[i].local_rank << endl;
}
system("pause");
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: