您的位置:首页 > 其它

POJ 1724 ROADS 带花费的最短路

2016-08-17 17:10 435 查看
ROADS

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Submit

Status

Description

N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).

Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.

The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

S is the source city, 1 <= S <= N

D is the destination city, 1 <= D <= N

L is the road length, 1 <= L <= 100

T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.

If such path does not exist, only number -1 should be written to the output.

Sample Input

5

6

7

1 2 2 3

2 4 3 3

3 4 2 4

1 3 4 1

4 6 2 1

3 5 2 0

5 4 3 2

Sample Output

11

//带花费的最短路问题

#include<stdio.h>
#include<string>
#include<cstring>
#include<queue>
#include<algorithm>
#include<functional>
#include<vector>
#include<iomanip>
#include<math.h>
#include<iostream>
#include<sstream>
#include<stack>
#include<set>
#include<bitset>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAXN=105;
const int MAXR=10005;
struct Status
{
int num,l,t;
bool operator < (const Status& x) const
{
if (l==x.l)
return t>x.t;
return l>x.l;
}
Status(int n,int a,int b):num(n),l(a),t(b) {};
};
int K,N,R,E;
int V[MAXR],Next[MAXR],First[MAXN],L[MAXR],T[MAXR];
void Init()
{
E=0;
memset(First,-1,sizeof(First));
memset(Next,-1,sizeof(Next));
}
void AddEdge(int a,int b,int c,int d)
{
V[E]=b,L[E]=c,T[E]=d;
Next[E]=First[a];
First[a]=E++;
}
int Dijkstra()
{
priority_queue<Status> que;
int Ans=INF;
que.push(Status(1,0,0));
while (!que.empty())
{
Status u=que.top();
que.pop();
if (u.num==N)
{
Ans=u.l;
break;
}
for (int i=First[u.num];i!=-1;i=Next[i])
if (u.t+T[i]<=K)
que.push(Status(V[i],u.l+L[i],u.t+T[i]));
}
return Ans==INF?-1:Ans;
}
int main()
{
int a,b,c,d;
while (scanf("%d%d%d",&K,&N,&R)!=EOF)
{
Init();
for (int i=0;i<R;i++)
{
scanf("%d%d%d%d",&a,&b,&c,&d);
AddEdge(a,b,c,d);
}
printf("%d\n",Dijkstra());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: