您的位置:首页 > 其它

POJ1426——Find The Multiple

2016-08-17 14:10 453 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27093 Accepted: 11266 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

Source

Dhaka 2002
题目大意:

输入一个数  n  ,求一个  n  的倍数,要求:这个倍数只能由  1  或  0 组成;

注意开头的红字   Special Judge   特殊判定    只要输出一组符合要求的就行

Memory: 2896K		Time: 282MS
Language: G++		Result: Accepted
Source Code
#include<iostream>
#include <cstdlib>
#include <cstdio>
#include <queue>

using namespace std;

int n;
queue<long long> a;

long long fun()
{
a.push(1);
while(!a.empty())
{
long long tp = a.front();
a.pop();
if( (tp*10)%n==0 )
return tp*10;
if( (tp*10+1)%n==0 )
return tp*10+1;
a.push(tp*10);
a.push(tp*10+1);
}
return -1;
}

int main()
{
while(cin>>n&&n)
{
while(!a.empty())
a.pop();
cout<<fun()<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 搜索 广搜