您的位置:首页 > 其它

POJ1651——Multiplication Puzzle(区间dp)

2016-08-17 13:38 375 查看
最近刷区间dp,先写水题

Multiplication Puzzle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8604 Accepted: 5375
Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on
the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output

Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5

Sample Output
3650


#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <iostream>
using namespace std;
const int MAXN =310;
const int INF =1000000007 ;
const int MOD =1000000007;
const double EPS=1e-8;
const double pi = acos(-1);

long long dp[MAXN][MAXN];
long long a[MAXN];
int main()
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%lld",a+i);
}
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
if(i>j)
dp[i][j]=0;
else
dp[i][j]=INF;
}
}
for(int i=1;i<n-1;i++)
dp[i][i]=a[i]*a[i+1]*a[i-1];
for(int k=1;k<=n-1;k++){
for(int i=1;i+k<n-1;i++){
int j=i+k;
//枚举断点
for(int m=i;m<=j;m++){
dp[i][j]=min(dp[i][j],dp[i][m-1]+dp[m+1][j]+a[m]*a[i-1]*a[j+1]);
}
}
}
printf("%lld\n",dp[1][n-2]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: