您的位置:首页 > 其它

hdu5810Balls and Boxes+数学期望

2016-08-16 21:18 239 查看
Problem Description

Mr. Chopsticks is interested in random phenomena, and he conducts an experiment to study randomness. In the experiment, he throws n balls into m boxes in such a manner that each ball has equal probability of going to each boxes. After the experiment, he calculated the statistical variance V as

V=∑mi=1(Xi−X¯)2/m

where Xi is the number of balls in the ith box, and X¯ is the average number of balls in a box.

Your task is to find out the expected value of V.

Input

The input contains multiple test cases. Each case contains two integers n and m (1 <= n, m <= 1000 000 000) in a line.

The input is terminated by n = m = 0.

Output

For each case, output the result as A/B in a line, where A/B should be an irreducible fraction. Let B=1 if the result is an integer.

Sample Input

2 1

2 2

0 0

Sample Output

0/1

1/2

Hint

In the second sample, there are four possible outcomes, two outcomes with V = 0 and two outcomes with V = 1.

Author

SYSU

Source

2016 Multi-University Training Contest 7

就是把n个球扔到m个箱子里。扔到每个箱子的概率是相等的,求箱子里球的个数的方差的期望。

这是个随机概率。每个箱子的概率相等,那么方差的期望就是总体的方差。

s=n*p*(1-p);

球等概率的扔到箱子里,所以p=1/m;

所以s=n∗(m−1)/m2

#include<cstdio>
#include<string>
#include<cmath>
#include<algorithm>
#include<iostream>

using namespace std;
#define LL long long

int main(){
LL n,m;
while(scanf("%I64d %I64d",&n,&m)!=EOF){
if(n==0&&m==0) break;
LL fz=n*(m-1);
LL fm=m*m;
LL gcd=__gcd(fz,fm);
fz=fz/gcd;
fm=fm/gcd;
printf("%I64d/%I64d\n",fz,fm);
}
return 0;
}


还有一个详细的推导过程(然而我都不会)



然而某神打表,观察出了规律。秒过。。然而并没有要到打表代码。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学期望