您的位置:首页 > 产品设计 > UI/UE

poj 2442 Sequence(贪心,堆)

2016-08-16 20:31 489 查看
Sequence

Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8976 Accepted: 2996
Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence,
and get n ^ m values. What we need is the smallest n sums. Could you help us?
Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer
in the sequence is greater than 10000.
Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.
Sample Input
1
2 3
1 2 3
2 2 3

Sample Output
3 3 4

Source
POJ Monthly,Guang Lin

题目大意;

给你m行,每行有n个数。 分别从每一行取一位数,然后加和。这样的数一定会构成m^n个。输出最小的n个即可。

动态维护前n小

用堆或优先队列都可以

heap实现:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn = 2005;
int a[maxn], b[maxn], sum[maxn];
int main(void)
{
int t, m, n;
cin >> t;
while(t--)
{
scanf("%d%d", &m, &n);
for(int i = 0; i < n; i++) scanf("%d", &a[i]);
for(int i = 1; i < m; i++)
{
sort(a, a+n);
for(int j = 0; j < n; j++) scanf("%d", &b[j]);
sort(b, b+n);
for(int j = 0; j < n; j++) sum[j] = a[j]+b[0];
make_heap(sum, sum+n);
for(int j = 1; j < n; j++)
for(int k = 0; k < n; k++)
{
int temp = b[j]+a[k];
if(temp >= sum[0]) break;
pop_heap(sum, sum+n);
sum[n-1] = temp;
push_heap(sum, sum+n);
}
for(int j = 0; j < n; j++) a[j] = sum[n-j-1];
}
sort(a, a+n);
for(int i = 0; i < n; i++)
{
if(i) printf(" ");
printf("%d", a[i]);
}
printf("\n");
}
return 0;
}


priority_queue实现:

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 2005;
int a[maxn], b[maxn];
int main(void)
{
int t, m, n;
cin >> t;
while(t--)
{
priority_queue<int, vector<int>, less<int> > pq;
while(!pq.empty()) pq.pop();
scanf("%d%d", &m, &n);
for(int i = 0; i < n; i++) scanf("%d", &a[i]);
for(int i = 1; i < m; i++)
{
sort(a, a+n);
for(int j = 0; j < n; j++) scanf("%d", &b[j]);
sort(b, b+n);
for(int j = 0; j < n; j++)
for(int k = 0; k < n; k++)
{
if(pq.size() == n && a[j]+b[k] >= pq.top()) break;
else if(pq.size() < n) pq.push(a[j]+b[k]);
else
{
pq.pop();
pq.push(a[j]+b[k]);
}
}
int k = 0;
while(!pq.empty())
{
a[k++] = pq.top();
pq.pop();
}
}
sort(a, a+n);
for(int i = 0; i < n; i++)
{
if(i) printf(" ");
printf("%d", a[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  优先队列 贪心