您的位置:首页 > 其它

POJ-2752 Seek the Name, Seek the Fame(KMP)

2016-08-16 15:16 344 查看
Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17146 Accepted: 8759
Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to
escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:) 

Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa

Sample Output
2 4 9 18
1 2 3 4 5

Source
POJ Monthly--2006.01.22,Zeyuan Zhu

题目大意:让求一个字符串的prefix-suffix,prefix-suffix的定义是

原字符串中既有这样的前缀,也有这样的后缀,从小到大输出其长度

思路:

对于第一个样例,ababcababababcabab

Next数组为 -1 1 2 1 2 3 4 3 4 3 4 5 6 7 8 9

Next[m]为9,即该字符串中最大前缀后缀匹配值为9,

也就是前9个与后9个的匹配是最大匹配,下面只需要匹配前9个前缀与后9个

的后缀的最大匹配值,又前后串相同,故只需要在前9个中迭代实现相同处理,

一次寻找Next[9]=4,Next[4]=2,Next[2]=0

参考自链接

/*

*/
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N = 400005;
char str
;
int Next
,num
;
void Getfail(int m)
{
Next[0] = -1;
int i = 0,j = -1;
while(i < m)
{
if(j == -1 || str[i] == str[j])
Next[++i] = ++j;
else
j = Next[j];
}
}
int main()
{
while(~scanf("%s",str))
{
memset(Next,0,sizeof(Next));
int m = strlen(str);
Getfail(m);
int k = Next[m],cnt = 0;
while(k > 0)
{
num[cnt++] = k;
k = Next[k];
}
for(int i = cnt -1;i >= 0;i--)
printf("%d ",num[i]);
printf("%d\n",m);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: