您的位置:首页 > 其它

HDU 2095 find your present (2)(位运算 或 排序做)

2016-08-16 13:38 573 查看
find your present (2)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 21466 Accepted Submission(s): 8432

Problem Description

In the new year party, everybody will get a “special present”.Now it’s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present’s card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5

1 1 3 2 2

3

1 2 1

0

Sample Output

3

2

Hint

Hint

use scanf to avoid Time Limit Exceeded

Author

8600

Source

HDU 2007-Spring Programming Contest - Warm Up (1)

分析:题意就是在N个数中找与众不同的那个数

思路:

1.对所有数排个序,从这个有序的数列中找就比较容易了

2.采用异或运算 ^, a^a^b^c^c^c=b 因为a^a=0 ,c^c^c=0,b^0=b ,所以重复的数全部消除掉了,只剩下的与众不同的那个数。

方法一:

#include<cstdio>
#include<algorithm>
using namespace std;
#define MAX 1000000+1
int num[MAX];

int main(){
int n;
while(scanf("%d",&n)!=EOF && n){
for(int i=0;i<n;i++)
scanf("%d",&num[i]);
sort(num,num+n);

int temp;
for(int i=1;i<n-1;i++)
if(num[i]!=num[i+1] && num[i]!=num[i-1]){
temp=i;
break;
}
if(num[0]!=num[1])
temp=0;
if(num[n-2]!=num[n-1])
temp=n-1;
printf("%d\n",num[temp]);
}
}


方法二:

#include<cstdio>
using namespace std;
int main(){
int n,x,temp;
while(scanf("%d",&n)!=EOF && n){
temp=0;
while(n--)
scanf("%d",&x),temp^=x;
printf("%d\n",temp);
}
}


位运算很神奇呢~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: