您的位置:首页 > 其它

HDU 3555 Bomb 数位DP

2016-08-15 22:17 429 查看


Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 15298    Accepted Submission(s): 5525


Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would
add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

Output

For each test case, output an integer indicating the final points of the power.

 

Sample Input

3
1
50
500

 

Sample Output

0
1
15

#include<stdio.h>
#include<string.h>
#define ll long long
ll dp[25][25];
ll query(ll n);
int main()
{
int i,j,k,sum,t;ll n;
dp[0][0]=1;
for(i=1;i<=24;i++)
{
for(j=0;j<10;j++)
{
for(k=0;k<10;k++)
{
if(!(j==4 && k==9))
{
dp[i][j]+=dp[i-1][k];
}
}
}
}
scanf("%d",&t);
while(t--)
{
scanf("%lld",&n);
printf("%lld\n",n-query(n+1)+1);
}
return 0;
}
ll query(ll n)
{
int i,j,a[25]={0},len=1;
while(n>0)
{
a[len++]=n%10;
n/=10;
}
ll ans=0;
for(i=len;i>=1;i--)
{
for(j=0;j<a[i];j++)
{
if(!(j==9 && a[i+1]==4))
ans+=dp[i][j];
}
if(a[i]==9 && a[i+1]==4)
break;
}
return ans;
}

dfs写法:dfs(len,m,flag):len表示当前位数m=0 表示没有连续49且上一位不是4m=1 表示没有连续49且上一位是4m=2 表示含有连续49flag=0 表示当前位可以取0~9都不会超限flag=1 表示当前位只可以取0~dis[len]。
只有当flag=0是才可以用dp[len][m]存入计数。
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
#define ll long long
const int maxm = 10005;
ll dp[25][3], dis[25];
ll dfs(int len, int m, int flag)
{
if (len < 0) return m == 2;
if (!flag&&dp[len][m] != -1) return dp[len][m];
int k = flag ? dis[len] : 9;
ll ans = 0;
for (int i = 0;i <= k;i++)
{
if (m == 2 || m == 1 && i == 9)
ans += dfs(len - 1, 2, flag&&i == k);
else if (i == 4)
ans += dfs(len - 1, 1, flag&&i == k);
else
ans += dfs(len - 1, 0, flag&&i == k);
}
if (!flag) dp[len][m] = ans;
return ans;
}
ll solve(ll n)
{
int len = 0;
while (n)
{
dis[len++] = n % 10;
n /= 10;
}
return dfs(len - 1, 0, 1);
}
int main()
{
ll t, n;
memset(dp, -1, sizeof(dp));
scanf("%lld", &t);
while (t--)
{
scanf("%lld", &n);
printf("%lld\n", solve(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: