您的位置:首页 > 其它

Jam's math problem

2016-08-15 21:31 190 查看
Jam's math problem

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

HDU 5615

Description

Jam has a math problem. He just learned factorization.

He is trying to factorize ax^2+bx+c into the form of pqx^2+(qk+mp)x+km=(px+k)(qx+m).

He could only solve the problem in which p,q,m,k are positive numbers.

Please help him determine whether the expression could be factorized with p,q,m,k being postive.

Input

The first line is a number T, means there are T(1 \leq T \leq 100 ) cases

Each case has one line,the line has 3 numbers a,b,c (1 \leq a,b,c \leq 100000000)

Output

You should output the "YES" or "NO".

Sample Input

2

1 6 5

1 6 4

Sample Output

YES

NO

Hint

就是看看能不能分解因式:

#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
int t;
long long a,b,c,i,j;
scanf("%d",&t);
while(t--)
{
int f=0;
scanf("%lld %lld %lld",&a,&b,&c);
for(i=1;i*i<=a;i++)
{
if(a%i!=0)
continue;
for(j=1;j*j<=c;j++)
{
if(c%j!=0)
continue;
if((i*(c/j)+j*(a/i))==b||(i*j+(c/j)*(a/i))==b)
{
f=1;
}
}
}
if(f==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  小数学