您的位置:首页 > 其它

UVA 562 Dividing coins (01背包)

2016-08-15 19:32 435 查看
 Dividing coins
Time Limit:3000MS     Memory Limit:0KB     64bit
IO Format:
%lld & %llu

Submit Status Practice UVA
562 

uDebug


      It’s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting overa nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce,they stretched the coin
to great length and thus created copper-wire.

      Not commonly known is that the fighting started, after the two Dutch tried to divide a bag withcoins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutchof the past couldn’t stand
the fact that a division should favour one of them and they always wanteda fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, butbeing capable of making an equal division as fair as possible is something that will
remain importantforever... 

      That’s what this whole problem is about. Not everyone is capable of seeing instantly what’s themost fair division of a bag of coins between two persons. Your help is asked to solve this problem.

      Given a bag with a maximum of 100 coins, determine the most fair division between two persons.This means that the difference between the amount each person obtains should be minimised. Thevalue of a coin varies from 1 cent
to 500 cents. It’s not allowed to split a single coin.

Input

A line with the number of problems n, followed by n times:• a line with a non negative integer m (m ≤ 100) indicating the number of coins in the bag• a line with m numbers separated by one space, each number indicates the value
of a coin.

Output

The output consists of n lines. Each line contains the minimal positive difference between the amountthe two persons obtain when they divide the coins from the corresponding bag.

Sample Input

2

3

2 3 5

4

1 2 4 6

Sample Output

0

1

题意:把硬币分成两堆,使两堆硬币的价值之和 相差最小。

思路:如果这道不是在背包专题中,我怎么也不会想到这是动态规划。。。。。。。。

要把硬币尽量平分为两堆,以硬币总价值的一半为背包的容积,然后就转换为01背包问题了。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[33000],dp[110][33000];//定义数组时要注意
int main()
{
int t,m,n,i,j,k,l,mid;
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%d",&n);
int sum=0;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
mid=sum/2;
for(i=1;i<=n;i++)
for(j=0;j<=mid;j++)
{
dp[i][j]=dp[i-1][j];
if(j>=a[i])
{
dp[i][j]=max(dp[i][j],dp[i-1][j-a[i]]+a[i]);
}
}
printf("%d\n",sum-2*dp
[mid]);
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: