您的位置:首页 > 其它

POJ 1142 Smith Numbers(我不管,水题我也要写博客)

2016-08-15 16:41 429 查看
Description

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that
number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:

4937775= 3*5*5*65837

The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers.

As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition.

Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a
Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0


Sample Output

4937775

题意:输入n,输入大于n的Smith数.注意素数不是Smith数.

思路:暴力,从n+1开始找,如果是素数就continue,否则算出各个位之和赋给s1,然后分解质因子并求和赋给s2,直到s1=s2.

本鶸:TLE 6次,CE 1次,WA 1次,MLE 1次

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
using namespace std;
bool isprime(int n)
{
if(n==1) return false;
for(int i=2;i*i<=n;i++)
if(n%i==0)
return false;
return true;
}
int cut(int n)
{
int rec=0;
if(n!=1)
while(n)
{
rec+=n%10;
n/=10;
}
return rec;
}
int simth(int n)
{
int rec=0;
int i=2;
while(i*i<=n)
{
while(n%i==0)
{
n/=i;
rec+=cut(i);
}
i++;
}
rec+=cut(n);
return rec;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n)
{
while(1)
{
n++;
if(isprime(n))
continue;
int s1=cut(n),s2=simth(n);
if(s1==s2)
{
printf("%d\n",n);
break;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: