您的位置:首页 > 其它

UVA 10200Prime Time(素数)

2016-08-15 16:27 369 查看
Euler is a well-known matematician, and, among many other things, he discovered that the formula

n

2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41.

Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known

that for n ≤ 10000000, there are 47,5% of primes produced by the formula!

So, you’ll write a program that will output how many primes does the formula output for a certain

interval.

Input

Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must

read until the end of the file.

Output

For each pair a, b read, you must output the percentage of prime numbers produced by the formula in

this interval (a ≤ n ≤ b) rounded to two decimal digits.

Sample Input

0 39

0 40

39 40

Sample Output

100.00

97.56
50.00

题意:问a到b之间素数所占百分比。

思路:直接打表会超时,10的八次方。对于a到b之间的数可以直接判断是否为素数,建立一个函数biao()来判断是否是素数,是返回1否则返回0,在建立一个数组记录该数是不是素数。然后找到ab之间的素数个数在计算即可。注意要确定精度,因为保存两位小数没有确立精度可能会出错。

代码:

#include<cstdio>
#include<cstring>
#include<math.h>
using namespace std;
#define MAXN 10010
long long su[MAXN];
long long biao(long long x)
{
long long i;
for(i=2;i*i<=x;i++)
{
if(x%i==0)
return 0;
}
return 1;
}
void qq()
{
long long i;
for(i=0;i<=10010;i++)
su[i]=biao(i*i+i+41);
}
int main()
{
long long a,b,i;
memset(su,0,sizeof(su));
qq();
while(~scanf("%lld %lld",&a,&b))
{
long long sum=b-a+1;
long long ans=0;
for(i=a;i<=b;i++)
{
if(su[i])
ans++;
}
double lv;
lv=ans*100.0/sum;
printf("%.2lf\n",lv);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: