您的位置:首页 > 其它

poj 1113 Wall (计算几何)

2016-08-15 16:11 435 查看
Wall

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35284 Accepted: 12007
Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall
towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources
to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build
the wall. 



Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices
in feet.
Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to
the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides
of the castle do not intersect anywhere except for vertices.
Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers
are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output
1628

Hint

结果四舍五入就可以了
Source

Northeastern Europe 2001
[Submit]   [Go Back]   [Status]  
[Discuss]

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 3003
#define eps 1e-8
using namespace std;
int n,l,tot;
struct Vector
{
double x,y;
Vector(double X=0,double Y=0)
{
x=X,y=Y;
}
bool operator ==(const Vector &a) const
{
return x==a.x&&y==a.y;
}
};
Vector operator -(Vector a,Vector b) {return Vector(a.x-b.x,a.y-b.y);}
Vector operator +(Vector a,Vector b) {return Vector(a.x+b.x,a.y+b.y);}
Vector operator *(Vector a,double b) {return Vector(a.x*b,a.y*b);}
Vector operator /(Vector a,double b) {return Vector(a.x/b,a.y/b);}
bool operator <(const Vector &a,const Vector &b)
{
return a.x<b.x||(a.x==b.x&&a.y<b.y);
}
typedef Vector point;
point ch
,p
;
Vector line
;
const double pi=acos(-1.0);
double dot(Vector a,Vector b)//点积
{
return a.x*b.x+a.y*b.y;
}
double cross(Vector a,Vector b)//叉积,叉积为0,两直线平行
{
return a.x*b.y-a.y*b.x;
}
int dcmp(double x)//精度控制
{
if (fabs(x)<eps) return 0;
else return x<0?-1:1;
}
double len(Vector a)//向量的模长
{
return sqrt(dot(a,a));
}
int convexhull(point* p,int n,point* ch)//Graham扫描法求凸包,把给定点包围在内,面积最小的凸多边形,注意该算法不能有重复的点,不能三点共线
{
sort(p,p+n);//把点按照X坐标排序
int k,i,m=0;//注意是从0开始存储的
for (int i=0;i<n;i++)//把p1,p2放到凸包中,从p3开始,当当前点在凸包前进方向的左边时,加入该点;否则弹出最后加入的点,直到新点在左边,这样就确定了下凸壳
{
while(m>1&&dcmp(cross(ch[m-1]-ch[m-2],p[i]-ch[m-2]))<=0) m--;
ch[m++]=p[i];
}
k=m;
for (int i=n-2;i>=0;i--)//然后反向确定上凸壳,因为之前下凸壳中的点是不能删去的所以m>k
{
while(m>k&&dcmp(cross(ch[m-1]-ch[m-2],p[i]-ch[m-2]))<=0) m--;
ch[m++]=p[i];
}
if (n>1) m--;
return m;
}
int main()
{
scanf("%d%d",&n,&l);
for (int i=0;i<n;i++)
scanf("%lf%lf",&p[i].x,&p[i].y);
tot=convexhull(p,n,ch);
for (int i=1;i<=tot;i++)
line[i]=ch[i]-ch[i-1];
line[tot+1]=ch[0]-ch[tot];
double ans=0;
for (int i=1;i<=tot+1;i++)
ans+=len(line[i]);
ans+=pi*l*2;
printf("%.0lf\n",ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: