您的位置:首页 > 其它

hdu5832-A water problem-续缘之路

2016-08-15 13:07 253 查看

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)



[align=left]Problem Description[/align]
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73
days in Xixi a year and 137
days in Haha a year.

Now you know the days N
after Big Bang, you need to answer whether it is the first day in a year about the two planets.

[align=left]Input[/align]
There are several test cases(about
5
huge test cases).

For each test, we have a line with an only integer
N(0≤N),
the length of N
is up to 10000000.
 

[align=left]Output[/align]
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

[align=left]Sample Input[/align]

10001
0
333

 

[align=left]Sample Output[/align]

Case #1: YES
Case #2: YES
Case #3: NO

比赛的时候先用java的BIGInteger水一发结果MLE了
然后再用java写一个模拟取余
又MLE了。。。
然后发现此题没有用java过的,顿时不开森。(对java党如此不友好=。=)
附上C++AC代码

#include<iostream>

#include<cstring>

using namespace std;

char shu[10000000];

int main()

{
int cs=0;
while(scanf("%s",&shu)!=EOF)
{
cs++;
long sum=0;
for(int i=0;i<strlen(shu);i++)
{
sum=(sum*10+shu[i]-'0')%10001;
}
printf("Case #%d: ",cs);
if(sum==0)
printf("YES\n");
else
printf("NO\n");
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: