您的位置:首页 > 其它

Matrix Power Series poj3233矩阵快速幂

2016-08-15 12:41 260 查看
Matrix Power Series

Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 20527 Accepted: 8612
Description

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative
integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input
2 2 4
0 1
1 1

Sample Output
1 2
2 3

令S[k]=I+A+……+A^(k-1)(其中I是单位矩阵)

时间复杂度为O(n^3logk)
AC代码:

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 65
typedef long long ll;
int Mod,n,k;
struct Matrix
{
int row,col;
ll mat

;
void init(int row,int col,bool ok=false){
this->row=row;
this->col=col;
memset(mat,0,sizeof(mat));
if(!ok) return;
for(int i=0;i<N;i++){
mat[i][i]=1;
}
}
Matrix operator *(const Matrix& B){
Matrix C;
C.init(row,B.col);
for(int k=0;k<col;k++){
for(int i=0;i<row;i++){
if(mat[i][k]==0) continue;
for(int j=0;j<B.col;j++){
if(B.mat[k][j]==0) continue;
C.mat[i][j]+=(mat[i][k]%Mod)*(B.mat[k][j]%Mod);
C.mat[i][j]=C.mat[i][j]%Mod;
}
}
}
return C;
}
Matrix pow(ll n){
Matrix B,A=*this;
B.init(row,col,1);
while(n){
if(n&1) B=B*A;
A=A*A;
n>>=1;
}
return B;
}
};
int main()
{
scanf("%d%d%d",&n,&k,&Mod);
Matrix A,B;
A.init(n,n);
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
scanf("%d",&A.mat[i][j]);
}
}
B.init(2*n,2*n);
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
B.mat[i][j]=A.mat[i][j];
}
B.mat[n+i][i]=B.mat[n+i][n+i]=1;
}
B=B.pow(k+1);
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
ll a=B.mat[n+i][j]%Mod;
if(i==j) a=(a+Mod-1)%Mod;
printf("%lld%c",a,j+1==n?'\n':' ');
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息