您的位置:首页 > 其它

Bone Collector(0-1背包模板)

2016-08-15 11:55 274 查看


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 51860    Accepted Submission(s): 21837


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 

0-1背包是最基础的背包问题,特点是:每种物品仅有一件,可以选择放或不放。

用子问题定义状态:即f[i][v]表示前i件物品恰放入一个容量为v的背包可以获得的最大价值。则其状态转移方程便是:

f[i][v]=max{f[i-1][v],f[i-1][v-c[i]]+w[i]}

这个方程非常重要,基本上所有跟背包相关的问题的方程都是由它衍生出来的。所以有必要将它详细解释一下:

“将前i件物品放入容量为v的背包中”这个子问题,若只考虑第i件物品的策略(放或不放),那么就可以转化为一个只牵扯前i-1件物品的问题。

在前i件物品放进容量v的背包时,它有两种情况:

f[i-1][v]:如果不放第i件物品,那么问题就转化为“前i-1件物品放入容量为v的背包中”,价值为f[i-1][v];

f[i-1][v-c[i]]+w[i]:如果放第i件物品,那么问题就转化为“前i-1件物品放入剩下的容量为v-c[i]的背包中”,此时能获得的最大价值就是f[i-1][v-c[i]]再加上通过放入第i件物品获得的价值w[i]。

最后比较第一种与第二种所得价值的大小,哪种相对大,f[i][v]的值就是哪种(这里是重点,理解!)。

 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int w[1010]={0};
int c[1010]={0};
int val[1010];
int main()
{
int t,i,j;
int N,V;
scanf("%d",&t);
while(t--)
{
memset(val,0,sizeof(val));
scanf("%d%d",&N,&V);
for(i=1;i<=N;i++){
scanf("%d",&w[i]);
}
for(i=1;i<=N;i++){
scanf("%d",&c[i]);
}
for(i=1;i<=N;i++)
{
for(j=V;j>=c[i];j--)
{
val[j]=max(val[j],val[j-c[i]]+w[i]);//这里可能 刚学的时候不理解,自己模拟一下就懂了;
}
}
printf("%d\n",val[V]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  背包