您的位置:首页 > 其它

HDU-2602-Bone Collector【01背包模板】

2016-08-15 11:50 399 查看
题目链接:点击打开链接

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 51862    Accepted Submission(s): 21839

[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).
 

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1

 

[align=left]Sample Output[/align]

14

一维数组:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int N,V;
int value[1010];
int volume[1010];
int dp[1010];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&N,&V);
for(int i=0;i<N;i++)
scanf("%d",&value[i]);
for(int i=0;i<N;i++)
scanf("%d",&volume[i]);
memset(dp,0,sizeof(dp));
for(int i=0;i<N;i++)
{
for(int j=V;j>=volume[i];j--)
{
dp[j]=max(dp[j],dp[j-volume[i]]+value[i]);
}
}
printf("%d\n",dp[V]);
}
return 0;
}

二维数组:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int N,V;
int val[1010];
int vol[1010];
int dp[1010][1010];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&N,&V);
for(int i=1;i<=N;i++)
scanf("%d",&val[i]);
for(int i=1;i<=N;i++)
scanf("%d",&vol[i]);
memset(dp,0,sizeof(dp));
for(int i=1;i<=N;i++)
{
for(int j=0;j<=V;j++)
{
dp[i][j]=dp[i-1][j];
if(j>=vol[i])
{
dp[i][j]=max(dp[i-1][j],dp[i-1][j-vol[i]]+val[i]);
}
}
/*	for(int j=vol[i];j<=V;j++)  错误的写法,当 j<vol[i] 的时候没有继承上一步的值
{
dp[i][j]=max(dp[i-1][j],dp[i-1][j-vol[i]]+val[i]);
}*/
}
printf("%d\n",dp
[V]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: