您的位置:首页 > 其它

HDU 1061 Rightmost Digit

2016-08-15 11:28 447 查看
Rightmost DigitTime Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d& %I64uSubmit Status Practice HDU1061DescriptionGiven a positive integer N, you should output the most right digit of N^N. InputThe input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000). OutputFor each te4000st case, you should output the rightmost digit of N^N. Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include<stdio.h>
int main()
{
__int64 i,n,sum,m;
while(scanf("%I64d",&n)!=EOF)
{

while(n--)
{
scanf("%I64d",&m);
sum=m;
for (i=2;i<=m%4+4;i++)
{
sum=sum*m%10;
}
printf("%I64d\n",sum);
}
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: