您的位置:首页 > 其它

HDU 1390 Binary Numbers

2016-08-14 23:58 393 查看

Binary Numbers

Problem Description

Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.

 

[align=left]Input[/align]
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

 

[align=left]Output[/align]
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

 

[align=left]Sample Input[/align]

1
13

 

[align=left]Sample Output[/align]

0 2 3

题意:给一个数,把它二进制所有的1的位置按顺序输出来。

其实不用转换二进制,直接位运算,因为位运算本来就是在二进制基础上操作的,左右移动去确定最后一位的值。

#include<stdio.h>
#include<string.h>
int main()
{
int t,n,i,j;
int a[100];
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int e=0,f=0;
while(n)
{
if(n>>1<<1!=n)
{
if(!f)
{
printf("%d",e);
f=1;
}
else
printf(" %d",e);
}
n>>=1;
e++;
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM HDU