您的位置:首页 > 其它

【杭电oj2028】Lowest Common Multiple Plus

2016-08-14 23:02 387 查看


Lowest Common Multiple Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 52009    Accepted Submission(s): 21589


Problem Description

求n个数的最小公倍数。

 

Input

输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

 

Output

为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

 

Sample Input

2 4 6
3 2 5 7

 

Sample Output

12
70

 

Author

lcy

 

Source

C语言程序设计练习(五)

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2046 1108 2044 2899 1215 

 

Statistic | Submit | Discuss | Note
算是GCD

#include<stdio.h>
#include<algorithm>
using namespace std;
int min(int a,int b);
int main() {
int n;
while(scanf("%d",&n)==1) {
int a[10000],k,ret;
for(int l=0; l<n; l++)
scanf("%d",&a[l]);
sort(a,a+n);
k=min(a[n-1],a[n-2]);
for(int l=n-3; l>=0; l--) {
ret=min(a[l],k);
k=ret;
}
printf("%d\n",k);
}
return 0;
}
int min(int a,int b) {
int i;
for(int i=a; i<=a*b; i++)
if(i%a==0&&i%b==0)
return i;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  GCD