您的位置:首页 > 其它

HDOJ 5832 a water problem(大数取模)

2016-08-14 20:17 399 查看
Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days
in Xixi a year and 137 days
in Haha a year. 

Now you know the days N after
Big Bang, you need to answer whether it is the first day in a year about the two planets.

 

Input

There are several test cases(about 5 huge
test cases).

For each test, we have a line with an only integer N(0≤N),
the length of N is
up to 10000000.

 

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

 

Sample Input

10001
0
333

 

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

 

Author

UESTC

 

Source

2016中国大学生程序设计竞赛
- 网络选拔赛 

 

Recommend

wange2014

总结:打卡题,直接大数取模过

#include<iostream>
#include<string>
#include<cstdio>
int const maxn=10000000+10;
char str[maxn];
using namespace std;
int main(){
//freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
int t=0;
while(scanf("%s",str)!=EOF)
{
t++;
int i;
int rem=0;
for(i=0;str[i];i++){
rem=rem*10+str[i]-'0';
rem=rem%10001;
}
printf("Case #%d: ",t);
if(rem==0) printf("YES\n");
else printf("NO\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: