您的位置:首页 > 其它

HDU 1009 FatMouse' Trade

2016-08-14 20:08 357 查看

FatMouse' Trade

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 67262    Accepted Submission(s): 22899
[/b]

[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.

 

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 

[align=left]Sample Output[/align]

13.333
31.500

 

[align=left]Author[/align]
CHEN, Yue
典型的贪心算法
用sort排序一下就好了;
#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;

struct asd{
int j;
int f;
double ave;
}mou[3005];
bool cmp(asd a,asd b)
{
return a.ave>b.ave;
}
int main()
{
int m,n;

while(~scanf("%d%d",&m,&n)&&(m!=-1||n!=-1))
{
int i;
for(i=0;i<n;i++)
{
scanf("%d%d",&mou[i].j,&mou[i].f);
mou[i].ave=(1.0*mou[i].j)/(1.0*mou[i].f);
}
sort(mou,mou+n,cmp);

double sum=0;
for(i=0;i<n;i++)
{

if(m>mou[i].f)
{
sum+=mou[i].j;
m=m-mou[i].f;
}

else
{
sum+=mou[i].ave*m;
m=0;

break;

}
}
printf("%.3lf\n",sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: