您的位置:首页 > 其它

【HDU 2120 Ice_cream's world I】

2016-08-14 19:15 302 查看
Ice_cream’s world I

Problem Description

ice_cream’s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded.

One answer one line.

Sample Input

8 10

0 1

1 2

1 3

2 4

3 4

0 5

5 6

6 7

3 6

4 7

Sample Output

3

#include<cstdio>
#define K 10011
int st[K],ans=0;
int find(int p)
{
int ch=p;
int t;
while(p!=st[p])
p=st[p];
while(ch!=p)
{
t=st[ch];
st[ch]=p;
ch=t;
}
return p;
}
void node(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
st[fx]=fy;
else
ans++;
}
int main()
{
int N,M,a,b,i;
while(scanf("%d%d",&N,&M)!=EOF)
{
for(i=0;i<=N;i++)
st[i]=i;
while(M--)
{
scanf("%d%d",&a,&b);
node(a,b);
}
printf("%d\n",ans);
ans=0;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: