您的位置:首页 > 其它

UVA 10200 Prime Time

2016-08-14 19:08 393 查看
题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1141

Prime Time

Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41. Even though this formula doesn’t always produce a prime,
it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula! So, you’ll write a program that will output how many primes does the formula output for a certain interval.

Input

Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file.

Output

For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits.

 

Sample Input

0 39

0 40

39 40

 

Sample Output

100.00

97.56

50.00

 
那么水的为什么比赛时没做出来呢,在想啥呢。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int init(int n)
{
for(int i=2;i*i<=n;i++)
if(n%i==0)
{
return 0;
}
return 1;
}
int main()
{
int a,b,i,j,num[10010];
memset(num,0,sizeof(num));
for(i=0;i<10010;i++)
num[i]=init(i*i+i+41);
int sum;
while(scanf("%d%d",&a,&b)!=EOF)
{
sum=0;
for(i=a;i<=b;i++)
sum+=num[i];
printf("%.2lf\n",sum*1.0/(b-a+1)*100+1e-8);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: