您的位置:首页 > 其它

UVA 10200 Prime Time (素数判定打表)

2016-08-14 15:03 393 查看

UVA 10200 Prime Time(简单素数判定预处理)

标签:
Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41
∗ 41. Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula! So, you’ll write a program that will output how many primes does the formulaoutput
for a certain interval.
Input
Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file.
Output
For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits. SampleInput
0 39
0 40
39 40
Sample Output
100.00
97.56
50.00
 #include<stdio.h>
#include<math.h>
#include<algorithm>
#include<string.h>
using namespace std;
#define G 11010
int num[G];
int sushu(int n)
{
int k = sqrt(n); //这里用n/2超时
for(int i = 2 ; i <= k ; i++)
{
if(n % i == 0)
return 0;
}
return 1;
}
void init()
{
num[0]=1;
for(int i = 1 ; i <G ; i++)
num[i] = num[i - 1] + sushu(i * i + i + 41);
}
int main()
{
int a, b,sum;
double p;
init();
while(scanf("%d%d", &a, &b)!=EOF)
{
sum= num[b] - num[a] + sushu(a * a + a + 41);
//printf("***%d****\n",sum);
p=(double)sum/(b-a+1)*100+ 1e-8;//这里如果不提高精度,会WA;
printf("%.2f\n",p);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: