您的位置:首页 > 其它

PAT甲级.1036. Boys vs Girls (25)

2016-08-14 01:25 477 查看

1036. Boys vs Girls (25)

题目:

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

输入格式:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

输出格式:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

输入样例1:

3

Joe M Math990112 89

Mike M CS991301 100

Mary F EE990830 95

输出样例1:

Mary EE990830

Joe Math990112

6

输入样例2:

1

Jean M AA980920 60

输出样例2:

Absent

Jean AA980920

NA

PAT链接

思路:

1.struct存储信息:

struct Info
{
char name[15];
char gender;
char ID[15];
int grade;

}FMax, MMin, tmp;


2.根据男女性别更新FMax和MMin

代码:

/**
* @tag PAT_A_1036
* @authors R11happy (xushuai100@126.com)
* @date 2016-8-14 0:32-0:50
* @version 1.0
* @Language C++
* @Ranking 200/3685
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cstring>

struct Info { char name[15]; char gender; char ID[15]; int grade; }FMax, MMin, tmp;

int main(int argc, char const *argv[])
{
//初始化
FMax.grade = -1;
MMin.grade = 101;
bool flag = true;
int N;
scanf("%d", &N);
while(N--)
{
scanf("%s %c %s %d", &tmp.name, &tmp.gender, &tmp.ID, &tmp.grade);
if(tmp.gender == 'F')
{
if(tmp.grade >= FMax.grade)
FMax = tmp;
}
else
{
if(tmp.grade <= MMin.grade)
MMin = tmp;
}
}
//输出最高分的Female
if(FMax.gender != 'F')
{
printf("Absent\n");
flag = false;
}
else
{
printf("%s %s\n", FMax.name, FMax.ID);
}

//输出最低分的Male
if (MMin.gender != 'M')
{
printf("Absent\n");
flag = false;
}
else
{
printf("%s %s\n", MMin.name, MMin.ID);
}
if (flag)
{
printf("%d\n", FMax.grade-MMin.grade);
}
else
printf("NA\n");
return 0;
}


收获:

更新前要注意初始化:

//初始化
FMax.grade = -1;
MMin.grade = 101;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: