您的位置:首页 > 其它

【LightOJ - 1058】Parallelogram Counting

2016-08-13 23:53 309 查看
 
                                                                                       Parallelogram
Counting
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1058 

uDebug


Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these
points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

Input starts with an integer T (≤ 15), denoting the number of test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines, contains 2space-separated integers x and y (the
coordinates of a point) with magnitude (absolute value) of no more than1000000000.

Output

For each case, print the case number and the number of parallelograms that can be formed.

Sample Input

2

6

0 0

2 0

4 0

1 1

3 1

5 1

7

-2 -1

8 9

5 7

1 1

4 8

2 0

9 8

Sample Output

Case 1: 5

Case 2: 6

根据平行四边形性质,两对角线中点一定重合,所以先取任意两点间的中点,然后在对这些中点排序sort一下,然后用组合数公式C(n,2)求出任意相同的点中任意两点组合的个数求和即可。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N = 1005;
struct node {
int x;
int y;
} s
,mid[N*N];
bool cmp(node A,node B) {
if(A.x==B.x)
return A.y<B.y;
return A.x<B.x;
}
int main() {
int T,p=0;
scanf("%d",&T);
while(T--) {
int n;
scanf("%d",&n);
for(int i=0; i<n; i++) {
scanf("%d%d",&s[i].x,&s[i].y);
}
int cnt=0;
for(int i=0; i<n; i++) {
for(int j=i+1; j<n; j++) {
mid[cnt].x=s[i].x+s[j].x;//不能除二,可能为奇数导致误差
mid[cnt].y=s[i].y+s[j].y;
cnt++;
}
}
sort(mid,mid+cnt,cmp);
int count=1,sum=0;
for(int i=0; i<cnt;i++) {
if(mid[i].x==mid[i+1].x&&mid[i].y==mid[i+1].y) {
count++;
} else {
sum=sum+count*(count-1)/2;
count=1;
}
}
printf("Case %d: %d\n",++p,sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学 平面几何