您的位置:首页 > 其它

light OJ Birthday Paradox.

2016-08-13 17:16 323 查看

 Birthday Paradox.

Description

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party
have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days
long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

#include<stdio.h>
int main()
{
int i,n,t,k=1;;
int ans;
double a;
scanf("%d",&t);
while(t--)
{
a=1.0;ans=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
a=a*(1.0*(n-i))/(n*1.0);
ans=i;
if(a<=0.5)
break;
}
printf("Case %d: %d\n",k++,ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: