您的位置:首页 > 其它

POJ 2309 BST

2016-08-13 16:01 369 查看
题目:

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating
going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers
for there queries. 



Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 2 31 -
1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10


Sample Output

1 15
9 11


代码:

#include<iostream>
using namespace std;

int main()
{
ios_base::sync_with_stdio(false);
int t;
cin >> t;
long long k;
for (int i = 1; i <= t; i++)
{
cin >> k;
cout << k - (k&(-k)) + 1 << " " << k + (k&(-k)) - 1 << endl;
}
return 0;
}


代码实在是简单,不过这个图倒是很有意思。

首先,这个图和树状数组的图是很像的。

其次,第一行都是奇数,第二行都是2的倍数,第三行都是4的倍数。。。

所以,这个图和汉诺塔问题也有着紧密的联系。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: