您的位置:首页 > 编程语言 > C语言/C++

hdu1029 Ignatius and the Princess IV 水题

2016-08-13 13:22 274 查看
Ignatius and the Princess IV

Time Limit: 1000MS Memory Limit: 32767KB 64bit IO Format: %I64d & %I64u
Submit Status

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says. 

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says. 

"But what is the characteristic of the special integer?" Ignatius asks. 

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says. 

Can you find the special integer for Ignatius? 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is
terminated by the end of file. 

Output

For each test case, you have to output only one line which contains the special number you have found. 

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1


Sample Output

3
5
1


既然这个数存在,那么对这个数组排序后数组正中间的位置就会是这个数。。。zhangjiatao1告诉我的。。。强啊

<pre name="code" class="cpp">#include<algorithm>
int main(){
int n,i,s[999999];
while(~scanf("%d",&n)){
for(i=0;i<n;i++)scanf("%d",s+i);
std::sort(s,s+n);
printf("%d\n",s[n/2]);
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 算法竞赛