您的位置:首页 > 其它

POJ-2407 Relatives(容斥原理模板)

2016-08-13 10:59 393 查看
Default
Relatives

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13534 Accepted: 6727
Description
Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0,
z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output
For each test case there should be single line of output answering the question posed above.
Sample Input
7
12
0

Sample Output
6
4

Source
Waterloo local 2002.07.01
求1到n-1里面与n互质的数的个数
#include <cstdio>
#include <cstring>
#include <cmath>
#define LL long long
#define MAX 10000000
using namespace std;
int p[1000], k;
void getp(int n)
{
int i, j;
k = 0;
for(i = 2; i*i <= n; i++)
{
if(n % i == 0)
{
p[k++] = i;
while(n % i == 0)
n /= i;
}
}
if(n > 1) p[k++] = n;
}
int nop(int n)
{
int top = 0;
int i, j, que[100000];
que[top++] = -1;
for(i = 0; i < k; i++)
{
int t = top;
for(j = 0; j < t; j++)
que[top++] = que[j]*p[i]*(-1);
}
int sum = 0;
for(i = 1; i < top; i++)
sum += n/que[i];
return sum;
}
int main()
{
int n;
while(scanf("%d", &n), n)
{
getp(n);
printf("%d\n", n-nop(n));
}
return 0;
}




                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: