您的位置:首页 > 其它

HDU(1513)Palindrome (lcs与回文串)

2016-08-13 08:43 316 查看

                               
    Palindrome 

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5237    Accepted Submission(s): 1793


[align=left]Problem Description[/align]
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted
into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

 

[align=left]Input[/align]
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from
'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

 

[align=left]Output[/align]
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

 

[align=left]Sample Input[/align]

5
Ab3bd

 

[align=left]Sample Output[/align]

2题目大意:给出一个字符串,求最少再添加多少个字符串会是其变成回文字符串:题解:先将字符串反向存入另一个字符串中,然后找出两者的最长公共子序列,然后用总长减去其长度即为所求:例题分析:原字符串:       A  b  3  b  d反向字符串:     d  b  3  b  A最长公共子序列:     b   3   d需要添加字符数:       5-3=2;举例分析:原字符串:        a    b   b   4  f   b 反向:           b     f  4   b  b  a最长公共:        b      4   b需要添加           6-3=3;原理分析:经过找正反字符最大公共序列中的字符可以通过添加相应字符使其左右对称,所以这些字符不需要再次添加:
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

char s1[5005],s2[5005];
int dp[2][5005],n;

void LCS()
{
int i,j;
memset(dp,0,sizeof(dp));
for(i = 1;i<=n;i++)
{
for(j = 1;j<=n;j++)
{
int x = i%2;
int y = 1-x;
if(s1[i-1]==s2[j-1])
dp[x][j] = dp[y][j-1]+1;
else
dp[x][j] = max(dp[y][j],dp[x][j-1]);
}
}
}

int main()
{
int i,j;
while(~scanf("%d",&n))
{
scanf("%s",s1);
for(i = 0;i<n;i++)
s2[i] = s1[n-1-i];
s2[i] = '\0';
LCS();
printf("%d\n",n-dp[n%2]
);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: