您的位置:首页 > 其它

Western Subregional of NEERC, Minsk, Wednesday, November 4, 2015 Problem I. Alien Rectangles 数学

2016-08-13 01:53 633 查看

Problem I. Alien Rectangles

题目连接:

http://opentrains.snarknews.info/~ejudge/team.cgi?SID=c75360ed7f2c7022&all_runs=1&action=140

Description

The spacecraft hovering above the surface of the faraway planet takes pictures of the landscape underneath

from time to time. Each photo is a circle centred at the point the spacecraft is orbiting over.

For detailed study of the planet’s surface researchers have chosen a Cartesian coordinate system on the

photos with the origin placed to the circle’s centre. The radius of the circle is R. The following stage of

the research requires selecting a region in the form of a nondegenerate rectangle with sides parallel to the

coordinate axes and with vertices at the points with integer coordinates. The points should lie inside or

on the boundary of the circle.

Please help the researchers and compute the total number of ways to choose a rectangular region. As the

number of ways may be big, output it modulo 109 + 2015.

Input

Input contains the only integer R (1 ≤ R ≤ 1 000 000).

Output

Output the only integer: the number of ways to choose a rectangle in the given circle modulo 109 + 2015.

Sample Input

2

Sample Output

9

Hint

题意

有一个中心在原点的圆,然后半径为R,问你里面以及圆上的整点,能够成多少个矩形。

题解:

算出每个坐标的点的个数,然后开始推公式就好了。

具体看代码。

至于看到只有一个数,就去推O1公式的,基本就走远了……

代码

#include <bits/stdc++.h>

using namespace std;

const int N=1000100;
const int pr=1e9 + 2015;
long long ans=0;

int main()
{
int R;
scanf("%d",&R);
int nx=1;
for(int i=1;i<=R;i++)
{
int x=i*2+1;
int y=(int)sqrt(1LL*R*R-1LL*i*i)*2+1;
long long t1,t2;
t1=1LL*x*(x-1)/2LL,t2=1LL*y*(y-1)/2LL;
if(t1>=pr) t1%=pr;
if(t2>=pr) t2%=pr;
ans+=(t1*t2%pr);
if(ans>=pr) ans%=pr;
t1=1LL*nx*(nx-1)/2LL,t2=1LL*y*(y-1)/2LL;
if(t1>=pr) t1%=pr;
if(t2>=pr) t2%=pr;
ans-=(t1*t2%pr);
if(ans<0) ans+=pr;
nx=x;
}
cout<<ans<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐