您的位置:首页 > 其它

POJ3259 Wormholes

2016-08-12 21:57 134 查看

 

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 44261   Accepted: 16285

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold

 

普通路是双向边!虫洞是单向边!所以边数组要开到M*2+W!

一定要好好看题呀,不然WA了都不知道为啥,一定要算好数据范围啊,不然RE了都不知道为啥……

 

至于问题本身,判图里有没有负环就行了。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
const int mxn=8000;
struct edge{
int v,dis;
int next;
}e[mxn];
int hd[mxn],cnt;
int n,m,w;
void add_edge(int u,int v,int dis){
e[++cnt].v=v;e[cnt].next=hd[u];e[cnt].dis=dis;hd[u]=cnt;
}
int inq[mxn],dis[mxn];
int vis[mxn];
bool SPFA(int s){
memset(vis,0,sizeof vis);
memset(dis,0x3f,sizeof dis);
memset(inq,0,sizeof inq);
queue<int>q;
inq[s]=1;dis[s]=0;vis[s]=1;
q.push(s);
while(!q.empty()){
int u=q.front();q.pop();
for(int i=hd[u];i;i=e[i].next){
int v=e[i].v;
if(dis[u]+e[i].dis<dis[v]){
dis[v]=dis[u]+e[i].dis;
vis[v]++;
if(vis[v]>n){
printf("YES\n");
return 0;
}
if(!inq[v]){
inq[v]=1;
q.push(v);
}
}
}
inq[u]=0;
}
return 1;
}
int main(){
int T;
scanf("%d",&T);
while(T--){
memset(hd,0,sizeof hd);
memset(e,0,sizeof e);
cnt=0;
scanf("%d%d%d",&n,&m,&w);
int i,j;
int x,y,d;
for(i=1;i<=m;i++){
scanf("%d%d%d",&x,&y,&d);
add_edge(x,y,d);
add_edge(y,x,d);
}
for(i=1;i<=w;i++){
scanf("%d%d%d",&x,&y,&d);
add_edge(x,y,-d);
}
bool flag=0;
for(i=1;i<=n;i++){
if(!SPFA(i)){flag=1;break;}
}
if(!flag)printf("NO\n");
}
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: