您的位置:首页 > 其它

HDU 5748 Bellovin (LIS)

2016-08-12 20:56 302 查看


Bellovin

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1072    Accepted Submission(s): 482


Problem Description

Peter has a sequence a1,a2,...,an and
he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn),
where fi is
the length of the longest increasing subsequence ending with ai.

Peter would like to find another sequence b1,b2,...,bn in
such a manner that F(a1,a2,...,an) equals
to F(b1,b2,...,bn).
Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an is
lexicographically smaller than sequence b1,b2,...,bn,
if there is such number i from 1 to n,
that ak=bk for 1≤k<i and ai<bi.

 

Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤100000) --
the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109).

 

Output

For each test case, output n integers b1,b2,...,bn (1≤bi≤109) denoting
the lexicographically smallest sequence.

 

Sample Input

3
1
10
5
5 4 3 2 1
3
1 3 5

 

Sample Output

1
1 1 1 1 1
1 2 3

 

Source

BestCoder Round #84

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  5831 5830 5829 5828 5827 

相当于求最长上升子序列

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 1000000010
using namespace std;
int dp[100010],a[100010],b[100010];
int main()
{
int t,n,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
fill(dp,dp+n,INF);
for(i=0;i<n;i++)
{
*lower_bound(dp,dp+n,a[i])=a[i];//将a[i]插入第一个小于它的位置
b[i]=upper_bound(dp,dp+n,a[i])-dp;//返回第一个小于等于它的数的位置
}
for(i=0;i<n;i++)
{
if(i!=n-1)
printf("%d ",b[i]);
else printf("%d\n",b[i]);
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: