您的位置:首页 > 其它

HDU-5748-Bellovin【LIS】

2016-08-12 19:55 302 查看
题目链接:点击打开链接



Bellovin

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit:
131072/131072 K (Java/Others)
Total Submission(s): 996    Accepted Submission(s): 447


Problem Description

Peter has a sequence a1,a2,...,an and
he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn),
where fi is
the length of the longest increasing subsequence ending with ai.

Peter would like to find another sequence b1,b2,...,bn in
such a manner that F(a1,a2,...,an) equals
to F(b1,b2,...,bn).
Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an is
lexicographically smaller than sequence b1,b2,...,bn,
if there is such number i from 1 to n,
that ak=bk for 1≤k<i and ai<bi.

Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤100000) --
the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109).

Output

For each test case, output n integers b1,b2,...,bn (1≤bi≤109) denoting
the lexicographically smallest sequence.

Sample Input

3
1
10
5
5 4 3 2 1
3
1 3 5

Sample Output

1
1 1 1 1 1
1 2 3

题意:

问题描述
Peter有一个序列a_1,a_2,...,a_na​1​​,a​2​​,...,a​n​​. 定义F(a_1,a_2,...,a_n)=(f_1,f_2,...,f_n)F(a​1​​,a​2​​,...,a​n​​)=(f​1​​,f​2​​,...,f​n​​), 其中f_if​i​​是以a_ia​i​​结尾的最长上升子序列的长度.

Peter想要找到另一个序列b_1,b_2,...,b_nb​1​​,b​2​​,...,b​n​​使得F(a_1,a_2,...,a_n)F(a​1​​,a​2​​,...,a​n​​)和F(b_1,b_2,...,b_n)F(b​1​​,b​2​​,...,b​n​​)相同. 对于所有可行的正整数序列, Peter想要那个字典序最小的序列.

序列a_1, a_2, ..., a_na​1​​,a​2​​,...,a​n​​比b_1, b_2, ..., b_nb​1​​,b​2​​,...,b​n​​字典序小, 当且仅当存在一个正整数ii (1 \le i \le n)(1≤i≤n)满足对于所有的kk (1 \le k < i)(1≤k<i)都有a_k = b_ka​k​​=b​k​​并且a_i < b_ia​i​​<b​i​​.


输入描述
输入包含多组数据, 第一行包含一个整数TT表示测试数据组数. 对于每组数据:

第一行包含一个整数nn (1 \le n \le 100000)(1≤n≤100000)表示序列的长度. 第二行包含nn个整数a_1,a_2,...,a_na​1​​,a​2​​,...,a​n​​ (1 \le a_i \le 10^9)(1≤a​i​​≤10​9​​).


输出描述
对于每组数据, 输出nn个整数b_1,b_2,...,b_nb​1​​,b​2​​,...,b​n​​ (1 \le b_i \le 10^9)(1≤b​i​​≤10​9​​)表示那个字典序最小的序列.

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAX=1e5+10;
const int INF=0x3f3f3f3f;
int n;
int dp[MAX];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
fill(dp,dp+n,INF);
int a,len;
for(int i=0;i<n;i++)
{
scanf("%d",&a);
len=lower_bound(dp,dp+n,a)-dp;
dp[len]=a; // 把数插入数组
printf(i==0?"%d":" %d",len+1);
}
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: