您的位置:首页 > 其它

poj3414Pots(bfs模拟数组 回溯路径)

2016-08-12 18:35 183 查看
Pots

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14309Accepted: 6034Special Judge
Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot
j is full (and there may be some water left in the pot i), or the pot
i is empty (and all its contents have been moved to the pot
j
).

Write a program to find the shortest possible sequence of these operations that will yield exactly
C liters of water in one of the pots.

Input

On the first and only line are the numbers A, B, and
C. These are all integers in the range from 1 to 100 and
C
≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations
K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain
the word ‘impossible’.

Sample Input
3 5 4

Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

Source
Northeastern Europe 2002, Western Subregion

#include<stdio.h>
#include<string.h>
struct node
{
int k1;//记录第一杯水的状态
int k2;//记录第二被水的状态
int step;//记录当前步数
int oper;//记录当前的操作
int pre;//记录前一步的编号
}q[110000];//数组开大一点  要不然wa
int vis[1100][1100];//标记两个水杯的状态是否出现
int a,b,c;
int flag;
int sum;//记录总的步数
int last;//记录最后一步的下标

void bfs()
{
memset(vis,0,sizeof(vis));
struct node tmp;
int head,tail;
head=tail=0;
tmp.k1=0;
tmp.k2=0;
tmp.step=0;
tmp.oper=0;
tmp.pre=0;
vis[0][0]=1;
q[tail++]=tmp;

while(head<tail)
{
tmp=q[head++];
if(tmp.k1==c||tmp.k2==c)
{
printf("%d\n",tmp.step);
sum=tmp.step;
last=head-1;
flag=1;
break;
}
struct node tmp1=tmp;
for(int i=1;i<=6;i++)
{
if(i==1)//fill(1)
{
tmp1.k1=a;
tmp1.k2=tmp.k2;
}
else if(i==2)//fill(2)

{
tmp1.k1=tmp.k1;
tmp1.k2=b;
}
else if(i==3)//drop(1);
{
tmp1.k1=0;
tmp1.k2=tmp.k2;
}
else if(i==4)//drop(2);
{
tmp1.k2=0;
tmp1.k1=tmp.k1;
}
else if(i==5)//pour(1,2);
{
if(tmp.k1+tmp.k2<=b)
{
tmp1.k1=0;
tmp1.k2=tmp.k1+tmp.k2;
}
else
{
tmp1.k1=tmp.k1+tmp.k2-b;
tmp1.k2=b;
}
}
else if(i==6)//pour(2,1);
{
if(tmp.k1+tmp.k2<=a)
{
tmp1.k2=0;
tmp1.k1=tmp.k1+tmp.k2;
}
else
{
tmp1.k2=tmp.k1+tmp.k2-a;
tmp1.k1=a;
}
}

if(!vis[tmp1.k1][tmp1.k2]&&tmp1.k1>=0&&tmp1.k1<=100&&tmp1.k2>=0&&tmp1.k2<=100)
{
tmp1.step=tmp.step+1;
tmp1.oper=i;
tmp1.pre=head-1;
q[tail++]=tmp1;
vis[tmp1.k1][tmp1.k2]=1;

}

}
}

}
int main()
{
int i,j,k;

while(~scanf("%d%d%d",&a,&b,&c))
{
int bh[11000];//记录编号
flag=0;//标记是否成功找到
bfs();
if(flag)
{

bh[sum]=last;//最后一步的编号
for(i=sum-1;i>0;i--)
{
bh[i]=q[bh[i+1]].pre;//本次的编号就是下一步里pre存的
}

for(i=1;i<=sum;i++)
{
if(q[bh[i]].oper==1)
printf("FILL(1)\n");
else if(q[bh[i]].oper==2)
printf("FILL(2)\n");
else if(q[bh[i]].oper==3)
printf("DROP(1)\n");
else if(q[bh[i]].oper==4)
printf("DROP(2)\n");
else if(q[bh[i]].oper==5)
printf("POUR(1,2)\n");
else if(q[bh[i]].oper==6)
printf("POUR(2,1)\n");
}
}
else printf("impossible\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: