您的位置:首页 > 其它

Poj 1195 Mobile phones

2016-08-12 17:16 453 查看

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4

1 1 2 3

2 0 0 2 2

1 1 1 2

1 1 2 -1

2 1 1 2 3

3

Sample Output

3

4

题目大意是 给你一个矩阵,

如果输入k为 0 就继续输入一个数n代表矩阵大小

如果k为 1 输入x y val 代表从[x][y] 一直到

整体加上val

如果为 2 输入x1 y1 x2 y2 求[x1][y1] [x2][y2]所构成的元素和

如果为 3 输入结束

其实就是一个二维树状数组,也可以用二维线段树,不过二维线段树不太会用

所以我用的是树状数组

代码如下

/*
二维树状数组模板,也可以用二维线段树,然而没学会...
*/
#include<cstdio>
#include<cstring>
#include<iostream>
#define M 1050
using namespace std;
int n;
int a[M][M];
int lowbit(int x) {
return x&(-x);
}
void add(int x,int y,int val) {
while(x<=n) {
int i=y;
while(i<=n) {
a[x][i]+=val;
i+=lowbit(i);
}
x+=lowbit(x);
}
}
int query(int x,int y){
int tot=0;
while(x) {
int i=y;
while(i) {
tot+=a[x][i];
i-=lowbit(i);
}
x-=lowbit(x);
}
return tot;
}
int main() {
int k;
while(scanf("%d",&k)!=EOF){
if(k==3) {break;}
if(k==0){
scanf("%d",&n);
memset(a,0,sizeof(a));
continue;
}
if(k==1) {
int x,y,val;
scanf("%d%d%d",&x,&y,&val);
x++;y++;
add(x,y,val);
continue;
}
if(k==2) {
int s=0;
int x1,y1,x2,y2;
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
x1++;y1++;x2++;y2++;
s=query(x2,y2)-query(x1-1,y2)-query(x2,y1-1)+query(x1-1,y1-1);
printf("%d\n",s);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj