您的位置:首页 > 其它

HDU 1394 Minimum Inversion Number

2016-08-12 16:44 441 查看
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)

a2, a3, ..., an, a1 (where m = 1)

a3, a4, ..., an, a1, a2 (where m = 2)

...

an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

 

[align=left]Input[/align]
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

 

[align=left]Output[/align]
For each case, output the minimum inversion number on a single line.

 

[align=left]Sample Input[/align]

10
1 3 6 9 0 8 5 7 4 2

 

[align=left]Sample Output[/align]

16

 
[align=left]树状数组更新单点值,求区间和。这里用到了一个数学知识:设ans为逆序和,a[i]输入的序列,则将a[i]移至队尾后,序列的逆序数变为ans=ans-a[i]+n-a[i]-1;在求出初次输入的逆序数后,进行一个 1~n for循环即可求解。代码如下:[/align]
#include<stdio.h>
#include<string.h>
int tree[5005],a[5005];
int n;
int lowbit(int x)
{
return x&-x;
}
int query(int x)
{
int s=0;
while(x>0)
{
s+=tree[x];
x-=lowbit(x);
}
return s;
}
void add(int x,int v)
{
while(x<=n)
{
tree[x]+=v;
x+=lowbit(x);
}
}
int main()
{
int i,x,ans;
while(scanf("%d",&n)!=EOF)
{
memset(tree,0,sizeof(tree));
memset(a,0,sizeof(a));
ans=0;
for(i=1;i<=n;++i)
{
scanf("%d",&a[i]);
ans+=query(n)-query(a[i]+1),add(a[i]+1,1);
}
x=ans;
for(i=1;i<=n;++i)
{
ans+=n-a[i]-a[i]-1;
if(x>ans) x=ans;
}
printf("%d\n",x);
}
return 0;
}
#include<stdio.h>
#include<string.h>
int tree[5005],a[5005];
int n;
int lowbit(int x)
{
return x&-x;
}
int query(int x)
{
int s=0;
while(x>0)
{
s+=tree[x];
x-=lowbit(x);
}
return s;
}
void add(int x,int v)
{
while(x<=n)
{
tree[x]+=v;
x+=lowbit(x);
}
}
int main()
{
int i,x,ans;
while(scanf("%d",&n)!=EOF)
{
memset(tree,0,sizeof(tree));
memset(a,0,sizeof(a));
ans=0;
for(i=1;i<=n;++i)
{
scanf("%d",&a[i]);
ans+=query(n)-query(a[i]+1),add(a[i]+1,1);
}
x=ans;
for(i=1;i<=n;++i)
{
ans+=n-a[i]-a[i]-1;
if(x>ans) x=ans;
}
printf("%d\n",x);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: