您的位置:首页 > 产品设计 > UI/UE

HDOJ 1159 Common Subsequence【模板题】

2016-08-12 15:56 369 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34223    Accepted Submission(s): 15602


[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

 

[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

 

[align=left]Sample Output[/align]

4
2
0

 

[align=left]Source[/align]
Southeastern Europe 2003
 

[align=left]Recommend[/align]
Ignatius
 

LCS模板题,下面贴上模板。

只要理解LCS,然后这题就是个模板题,没有难度。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char ch1[1111],ch2[1111];
int dp[1111][1111];
int main()
{
int i,j;
while(~scanf("%s%s",ch1,ch2))
{
memset(dp,0,sizeof(dp));
int l1=strlen(ch1);
int l2=strlen(ch2);
for(i=1;i<=l1;i++)
{
for(j=1;j<=l2;j++)
{
if(ch1[i-1]==ch2[j-1])
dp[i][j]=dp[i-1][j-1]+1;//相等的话+1
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);//不相等选之前状态下最长的那个
}
}
printf("%d\n",dp[l1][l2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: