您的位置:首页 > 其它

Binary Tree Traversals

2016-08-12 09:26 309 查看
Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can
be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2. 

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder. 

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder. 

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r. 

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence. 



 

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and
inorder sequence. You can assume they are always correspond to a exclusive binary tree. 

 

Output

For each test case print a single line specifying the corresponding postorder sequence. 

 

Sample Input

 9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

 

Sample Output

 7 4 2 8 9 5 6 3 1 #include<iostream>
#include<cstdlib>
#include<cstdio>
using namespace std;
typedef struct node
{
int data;
struct node *l,*r;
}tree;
tree *creat(int *pre,int *in,int len)
{
tree *head;
if(len<=0)
return NULL;
head = (tree *)malloc(sizeof(tree));
int *p;
head->data = *pre;
for(p=in;p!=NULL;p++)
if(*p == *pre)
break;
int lon = p-in;
head->l = creat(pre+1,in,lon);
head->r = creat(pre+lon+1,p+1,len-lon-1);
return head;
}
void last(tree * root)
{
if(root)
{

last(root->l);
last(root->r);
printf("%d ",root->data);
}
}
int main()
{
int n;
int pre[1001],in[1001];
while(scanf("%d%*c",&n))
{
for(int i=0;i<n;i++)
cin>>pre[i];
for(int i=0;i<n;i++)
cin>>in[i];
int len = n;
tree * root = creat(pre,in,len);
last(root);
puts("");
}
return 0;
}
原来写过类似的题目,可是是用的字符串,现在一给出int类型,刚一开始就蒙圈了。真是……
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: