您的位置:首页 > 其它

HDU 5821 Ball

2016-08-11 23:01 239 查看

Ball

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 376 Accepted Submission(s): 225


[align=left]Problem Description[/align]
ZZX has a sequence of boxes numbered 1,2,...,n. Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1≤i≤n, if the i-th box is empty then a[i]=0, otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.

[align=left]Input[/align]
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a
. Third line contains b[1],b[2],...,b
. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.

[align=left]Output[/align]
For each testcase, print "Yes" or "No" in a line.

[align=left]Sample Input[/align]

5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4

[align=left]Sample Output[/align]

No
No
Yes
No
Yes

/* ***********************************************
Author        :guanjun
Created Time  :2016/8/11 22:43:14
File Name     :hdu5821.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
priority_queue<int,vector<int>,greater<int> >pq;
struct Node{
int x,y;
};
struct cmp{
bool operator()(Node a,Node b){
if(a.x==b.x) return a.y> b.y;
return a.x>b.x;
}
};

bool cmp(int a,int b){
return a>b;
}
int a[maxn],b[maxn],l[maxn],r[maxn];
bool vis[maxn];
int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt","r",stdin);
#endif
//freopen("out.txt","w",stdout);
int t,n,m;
cin>>t;
while(t--){
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)scanf("%d",&a[i]);
for(int i=1;i<=n;i++)scanf("%d",&b[i]);
for(int i=1;i<=m;i++)scanf("%d%d",&l[i],&r[i]);
cle(vis);
int mark=0;
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
if(a[i]==b[j]&&!vis[j]){
a[i]=j;vis[j]=1;break;
}
else if(j==n){
mark=1;break;
}
}
}
if(mark)puts("No");
else{
for(int i=1;i<=m;i++){
sort(a+l[i],a+r[i]+1);
}
for(int i=1;i<=n;i++){
if(a[i]!=i){
mark=1;break;
}
}
if(mark)puts("No");
else puts("Yes");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: