您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2016-08-11 21:58 218 查看

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

输入

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

输出

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

 

示例输入

abc,,de,g,,f,,,


示例输出

cbegdfa
cgefdba


提示

 

来源

 xam

示例程序

#include<stdio.h>

#include<string.h>

#include<stdlib.h>

char ch[51];

int len,len1;

struct node

{

 char data;

 struct node *lchild,*rchild;

};

struct node *CreateTree()  //建树

{

 struct node *root;

 if(len<len1)

 {

  char c=ch[len++];

   if(c==',')

    return NULL;

   else

   {

     root=(struct node *)malloc(sizeof(struct node));

     root->data=c;      //根

     root->lchild=CreateTree();

     root->rchild=CreateTree();

   }

 }

 return root;

}

void LDR(struct node *root)

{

 if(root)  //树不为空

 {

LDR(root->lchild);

printf("%c",root->data);

LDR(root->rchild);

 }

}

void LRD(struct node *root)

{

 if(root)

 {

 LRD(root->lchild);

 LRD(root->rchild);

 printf("%c",root->data);

 }

}

int main()

{

 struct node *root;

 while(~scanf("%s",ch))

 {

  len=0;

  len1=strlen(ch);

  root=CreateTree();

        LDR(root);

        printf("\n");

        LRD(root);

        printf("\n");

 }

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: