您的位置:首页 > 其它

Pie--二分答案

2016-08-11 21:00 246 查看
Pie

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15241 Accepted: 5217 Special Judge
Description


My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are
coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input

One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output
25.1327
3.1416
50.2655

题目链接:http://poj.org/problem?id=3122

典型的二分答案

题意是说http://blog.csdn.net/lyy289065406/article/details/6648565大神的博客,膜拜中。。。

我还是看了题解才会的。。哎,明知道是什么知识点都不会做。。。

一定要注意加上自己!!!!

还有,我终于注意%f了!!!!哈哈哈

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#define eps 1e-7
#define pi 3.14159265359
using namespace std;
double a[100000];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
m++;
int i;
double maxc=0x3f3f3f3f;
for(i=0;i<n;i++)
{
scanf("%lf",&a[i]);
a[i]*=a[i];
if(maxc<a[i])
maxc=a[i];
}
double low=0.0;
double high =maxc;
double mid;
while(high-low>eps)
{
mid=(high+low)/2.0;
int sum=0;
for(i=0;i<n;i++)
{
sum+=(int )(a[i]/mid);
}
if(sum<m)
high=mid;
else
low=mid;
}
printf("%.4f\n",mid*pi);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: