您的位置:首页 > 其它

HDU 5821 ball

2016-08-11 20:56 267 查看
Problem Description

ZZX has a sequence of boxes numbered 1,2,...,n.
Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1≤i≤n,
if the i-th
box is empty then a[i]=0,
otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.

 

Input

First line contains an integer t. Then t testcases follow. 

In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a
. Third line contains b[1],b[2],...,b
. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.

 

Output

For each testcase, print "Yes" or "No" in a line.

 

Sample Input

5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4

 

Sample Output

No
No
Yes
No
Yes

 

贪心的去想结论,首先两个序列排序完一定是一样的,否则是No

然后考虑b中每个点从哪里来,假如b[i]=k是b中第j个k,那么这个k应该也是a中的第j个k.

于是把a中每个点对应的最终位置标记出来,操作就等于进行区间排序,如果结果不是c[i]=i那就是No了

#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
#define lson x << 1, l, mid
#define rson x << 1 | 1, mid + 1, r
#define fi first
#define se second
#define mp(i,j) make_pair(i,j)
#define pii pair<int,int>
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e3 + 10;
const int read()
{
char ch = getchar();
while (ch<'0' || ch>'9') ch = getchar();
int x = ch - '0';
while ((ch = getchar()) >= '0'&&ch <= '9') x = x * 10 + ch - '0';
return x;
}
int T, n, m, a
, b
, l, r, f
, c
, flag;

int main()
{
T = read();
while (T--)
{
scanf("%d%d", &n, &m);
rep(i, 1, n) a[i] = read();
rep(i, 1, n) b[i] = read();
rep(i, 1, n) f[i] = 0;
flag = 0;
rep(i, 1, n)
{
rep(j, 1, n)
{
if (f[j] || b[i] != a[j]) continue;
flag += f[j] = 1; c[j] = i; break;
}
}
rep(i, 1, m)
{
scanf("%d%d", &l, &r);
if (flag < n) continue;
sort(c + l, c + r + 1);
}
rep(i, 1, n) if (c[i] != i) flag = 0;
printf("%s\n", flag < n ? "No" : "Yes");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU