您的位置:首页 > 其它

poj1426 Find The Multiple

2016-08-11 20:45 302 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26508 Accepted: 10977 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111


这个题是给你一个数n让你找一个n的倍数m,这个m必须满足每一位都是1或者0。可以输出任何一个m。

因为必须满足每一位都是1或者0,那我们可以从1开始每次搜索*10和*10+1即可。

找到之后就输出返回就可以了

这里肯定使用long long 了。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <cmath>
using namespace std;
const int MAXN=30+5;
typedef long long ll;

void bfs(const ll n)
{
ll i=1,k;
queue<ll>q;
q.push(i);
while(!q.empty())
{
k=q.front();
q.pop();
if(k%n==0)
{
printf("%lld\n",k);
return ;
}
q.push(k*10);
q.push(k*10+1);
}
}

int main()
{
int n;
while(~scanf("%d",&n)&&n)
{
bfs(n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj bfs