您的位置:首页 > 其它

HDU 1025:Constructing Roads In JGShining's Kingdom(LIS问题+二分)

2016-08-11 16:16 465 查看
Description

JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample.

You should tell JGShining what’s the maximal number of road(s) can be built.

Sample Input

2

1 2

2 1

3

1 2

2 3

3 1

Sample Output

Case 1:

My king, at most 1 road can be built.

Case 2:

My king, at most 2 roads can be built.

题意:输入一个n,代表有n个贫穷的城市和n个富裕的城市,接下来n行,每行有一个贫穷的城市和一个富裕的城市可以进行修路,要求修的路不能交叉,而城市的排列可以认为是两排,从左到右按顺序排列,一排贫穷,一排富裕

题解:将贫穷的国家或者富裕的国家用sort快排,然后按照LIS分别计算

这里使用了一个函数 lower-bound(g,g+n,r),返回一个非递减数组g[i]里第一个比r的值大的值的位置,具体看代码

代码(C)

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
#define maxn 500050
using namespace std;
int g[maxn],a[maxn],dp[maxn];

struct lu
{
int a,b;
}e[maxn];

bool cmp(lu q,lu p)
{
return q.a<p.a;
}

int main()
{
int n,k,ans,r;
r=1;
while(scanf("%d",&n)!=EOF)
{
memset(g,inf,sizeof(g));//g数组用来记录从小到大的数字串
memset(dp,0,sizeof(dp));
ans=0;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&e[i].a,&e[i].b);
}
sort(e+1,e+1+n,cmp);//快排
for(int i=1;i<=n;i++)
{
k=lower_bound(g+1,g+n+1,e[i].b)-g;//找出第一个比e[i].b大的数,比如Case 1,k的返回值是1,即此时没有值比它小
dp[i]=k;//返回值是多少,代表g数组中按照顺序已经存入了几个比它小的数
if(e[i].b<g[k])  g[k]=e[i].b;//如果此时e[i].b比g数组中的第k个数小,将它更新为数组中最大的值,方便后面有更多的数字存入g;
if(ans<dp[i])  ans=dp[i];//其实这里的ans也就是在跟k比较,如果加入当前的数可以让ans更大,那么就按照题目要求输出更大的答案
}
if(ans==1)  printf("Case %d:\nMy king, at most %d road can be built.\n\n",r,ans);
else  printf("Case %d:\nMy king, at most %d roads can be built.\n\n",r,ans);//这里要注意,ans大于1时road要加s成为复数
r++;
}
return 0;
}//如果实在看不懂建议调试跟着走一遍就能理解了,一直盯着代码不调试是很难看懂代码的意图的
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: