您的位置:首页 > 大数据 > 人工智能

POJ 1218 The Drunk Jailer

2016-08-11 12:54 477 查看
题目:

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 

One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the hall locking every other cell
(cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He repeats this for n rounds, takes a final drink,
and passes out. 

Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 

Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number
of cells n. 

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells. 

Sample Input

2
5
100


Sample Output

2
10


这个题目就是找规律。

每个门被改变的次数是它的编号有多少个约数。

所以说,这个题目就是要求,从1到n有多少个数有奇数个约数。

然而,当且仅当一个数是完全平方数的时候它有奇数个约数。

所以只要输出int(sqrt(n))即可

当然,n这么小,找到平方不超过n的最大数可以直接枚举。

代码:

#include<iostream>
using namespace std;

int main()
{
ios_base::sync_with_stdio(false);
int t, n;
cin >> t;
while (t--)
{
cin >> n;
int i = 1;
while (i*i <= n)i++;
cout << i - 1 << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: