您的位置:首页 > 其它

Poj(1466),最大独立集,匈牙利算法

2016-08-11 10:53 417 查看
题目链接:http://poj.org/problem?id=1466

Girls and Boys

Time Limit: 5000MSMemory Limit: 10000K
Total Submissions: 12026Accepted: 5355
Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.
Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.
Output

For each given data set, the program should write to standard output a line containing the result.
Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

Source

Southeastern Europe 2000

题意:
就是有n个人,每个人与其他的某几个人有关系,这个关系且称为浪漫关系,然后最后求一个最大的集合,使得集合中所有的人两两之间都不存在浪漫关系。
分析:
1、最大独立集 = 顶点数 - 最大匹配数
2、匈牙利算法
3、这里的男女性别没有给出,匹配关系放大一倍,那么实际的匹配数就是/2了。

#include <stdio.h>
#include <string.h>

#define MAX 505

int n;
bool maps[MAX][MAX];
bool use[MAX];
int match[MAX];

bool DFS(int stu)
{
int num = 0;
for(int i=0; i<n; i++)
{
if(!use[i]&&maps[stu][i])
{
use[i] = true;
if(match[i]==-1||DFS(match[i]))
{
match[i] = stu;
return true;
}
}
}
return false;
}

int main()
{
while(scanf("%d",&n)!=EOF)
{
memset(match,-1,sizeof(match));
memset(maps,false,sizeof(maps));
for(int i=0; i<n; i++)
{
int u,num;
scanf("%d: (%d)",&u,&num);
for(int i=0; i<num; i++)
{
int v;
scanf("%d",&v);
maps[u][v] = true;
}
}
int num = 0;
for(int i=0; i<n; i++)
{
memset(use,false,sizeof(use));
if(DFS(i)) num++;
}
printf("%d\n",n-num/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: